PLC论坛-全力打造可编程控制器专业技术论坛

 找回密码
 注册哦

QQ登录

只需一步,快速开始

微信扫码登录

查看: 94|回复: 0

[三菱] 举例说明 PLC调试,模拟量跳变、掉线或无穷大,怎么破?

[复制链接]
发表于 2024-5-22 07:56:25 | 显示全部楼层 |阅读模式
下面是一个变频器对PLC模拟量干扰的例子以及用信号隔离模块克服此类干扰的解决办法。
一、举例1   现象说明
西门子PLC中AO点发出一路4-20mA电流控制信号,输出至西门子变频器,无法控制变频器启动。



故障查找
1、疑似模拟量输出板卡问题,用万用表测量4-20mA输出信号,信号是正常的!
2、开始怀疑是变频器控制信号输入端有了问题,换了一台同型号变频器,问题仍然如此。
3、用一台手持式信号发射器做4-20mA输出信号源,输出标准电流信号至变频器,这下变频器启动了,因而我们排除了模拟量输出板卡和变频器的故障。
4、由此推测是变频器的干扰信号传导至模拟量通道所致。
5、为了验证,在PLC模拟量4-20mA输出通道中加装了一台信号隔离模块TA3012,TA3012的输入端子5、6接模拟量输出模块,输出端子1、2端子接变频器,3、4端子接外部24VDC供电电源,变频器正常启动了。
6、据此断定,问题的根源在于变频器干扰模拟量通道所致。





注意事项
在PLC和变频器同时使用的自控系统中,应该着重注意一下事项:
PLC供电电源与动力系统电源(变频器电源)分别配置,且PLC的供电应该选择隔离变压器;
动力线尽量与信号线分开,信号线要做屏蔽;
无论是模拟信号输入还是模拟信号输出,模拟量通道一律使用信号隔离模块;
PLC程序里做软件滤波设计;
信号地与动力地分开设计。


二、举例2
“车间有10台250KW电机,负载为高压泵。变频器用施耐德ATV71跟PLC通过DP联接,PLC使用的西门子300,压力变送器为西门子,变送器到PLC为4-20mA模拟量,中间使用屏蔽线输入。


调试好后运行一周一切正常。厂家走后,开机忽然出现8号泵,设定40公斤压力,实际值为70公斤。设定80公斤压力实际值为110公斤。刚开始怀疑传感器故障,替换到其他泵上一切正常。之后变频器全开,3,4,5,6,7,9,10号泵也出现类似问题。


推测为压力传感器受到变频器干扰造成。厂家建议增加金属管屏蔽。但是考虑到现场施工难度(控制室距电机30多米,全部走的地下线缆沟)。认为变频器的谐波干扰应该是压力值上下波动,很少见到有干扰造成呈线性增大的。刚开始怀疑厂家程序有问题,因为显示屏这边始终显示的压力值是40公斤,但是变频器却输出70公斤的频率。厂家不同意该观点,说自己绝对用的西门子标准PID块。


百思不得其解。无意中发现,厂家传感器负跟屏蔽层同时接入到PLC模拟量输入端的M。拆下屏蔽线后将其接入设备的地后故障消除。


推测:2线制传感器,正极有PLC提供24V电压,负极则是传感器用来输出4-20mA电流的地方。屏蔽线跟负极接到一起后,屏蔽线上的感应电动势产生电流一起进入了PLC输入端造成了一个叠加的电流,从而形成压力值线性的增加。结果运行没2天又出现同样情况,并且更严重的是其中一个压力传感器拆除了居然还有40公斤压力,最终检查发现PLC输入侧负极剥线剥长了,相互之间短路了,造成其他通道的信号串出来了。


这才想起来,刚开始调试的时候厂家问我是不是设备地跟柜子地不在一个地上。压力传感器屏蔽线2端接地后,干扰还特别厉害。都无法显示。我也没多想随口来了句,单端接地。之后他们说好了。现在想来,应该是当初每个传感器的电流输出侧都通过屏蔽线联到了一起造成了短路,之后拆除了传感器侧的地线。由于屏蔽线没接到一起所以信号正常了。

免责声明:本文系网络转载或改编,版权归原作者所有。如涉及版权,请联系删除!

免责声明:如果侵犯了您的权益,请联系站长,我们会及时删除侵权内容,谢谢合作!

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有账号?注册哦

x
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册哦

本版积分规则

QQ|小黑屋|手机版|Archiver|PLC技术网-PLC论坛 ( 粤ICP备17165530号 )|网站地图

GMT+8, 2024-6-20 09:55 , Processed in 0.045445 second(s), 26 queries .

快速回复 返回顶部 返回列表